Frequent Asked Questions

All in and running now, little bit concerned as the Clarisea is filling up due to the filter becoming blocked up, my return chamber is running low, the tunze then tops it up, then as the Filter roll runs around to a clean bit the water drains out back into my sump and then raises the level. Setting off the tunze alarm as the level is to high.

I think I know how to over come it.
Split off the float from the level sensor, when the Clarisea is just about to rotate the roll,set the level sensor at that level and set the float on the spare magnet that comes with it at my high level as normal.

When the filter roll turns the level will rise and cover the level sensor, but I can’t see that being a problem and as the water evaporates the sensor will pick it up and trigger the pump to fill again.

I don’t think it would be a problem on larger systems as the return chambers aren’t as small as mine and not so sensitive to fluctuations.

Just got to find my spare magnet and float holder to prove my theory.

Best Regards..

I need help setting up a good light schedule that also has a good lunar set up I would like it to be a really dim clear white light but enough to see into the tank I everyone i talk to says something different about the liggt set up so I don't know i have 3 hydra 26s in a 120 gallon tank thanks for the help

Hi my sk300 is not working it is just one week old since the frist frist day it has not worked alarm keeps going off I reset the switch and the motor turns twice third time it rolls the alarm keep going off back to the same problem I think that it need to go back ?? Thank you  r .martin

hi tony,  what is the required flow through the 39w uv to kill whitespot so i can put the exact pump needed on please ?

dear sirs
i am writing to you to let you know how bitterly disappointed i am regarding your lack of customer satisfaction . as i purchased sol lights for almost £2000 , was told that they would last for a good 8 years.  and when 1 led goes down after 2.5 years to find out from my retailer that you do not support this product anymore
 i think it is totally disgusting and entrapment to make people buy later models .
so what happens when a newer version comes out after the hydra 52 ?  they will be discarded to the scrap heap for further entrapment for profit ? after customers have paid over £2000 ?
 with everyone recycling and trying to improve on not throwing items away , i wanted you to know i think your way of running a business is both just greed and has no respect for the customer , who is already in an expensive hobby that could do with a little help at times , and certainly a little co-operation
            a very unhappy  customer, whom will do everything NOT  to buy your products  again !!!!

       G. Bell

hi folks, have just obtained a new redsea reefer 525xl and looking to bye a recomended sump pump and skimmer to suit. the tank is said to hold 525 lts of water. have asked the same questions on differant chat webs but no answers then come across your page.
many thanks
colin

hi I have just purchased and installed the clarisea sk-5000


First question should it of come with any instructions as I didn't get any


Second problem I have come home twice and the alarm has been going off the water level isn't at the float switch height. if I reset it them everything works ok and it works again. I can make it wind by lifting the float switch so I don't think it had Jammed .
any ideas why it is doing this

Regards IAN

Hi,I have 2 20w UV units and today noticed one wasn't on.At first I thought the bulb might have failed, but looking at the power packs, the light is red on the one that isn't working, where as the light is green on the one that is working fine.Does the red light signal a power pack issue, or is it the light that has gone?Many thanksAdam

Hi,
    
    Is there any reason why this unit can't be hooked up to an outside waterbuttt collecting rainwater? I understand it has to work under pressure which could be achieved with a Waterbutt pump?
    
    Best regards
    
    Joey

Good afternoon, I am hoping you can assist, I am purchasing  Red Sea Reefer 425XL
and am wondering which model of skimmer you recommend.
The tank will be moderately stock with fish and coral and approx 40KG of live rock.
Please can you advise , many thanks, Kevin.

In recently purchased your product with the pump included 

 

However no matter what settings I have the valve on the pellets are not agitating. There is water flowing out of the return pipe but the pellets just sit on the bottom sponge and don’t seem to move. I have reduced the amount of pellets to less than 1/4 of what is recommended for my tank size 350 ltr

 

The top and bottom sponge are in place and the amount of pipe between the pump and the reactor head which is probably 5 ft from ground is just enough to have a small kink in it so as to give me room to empty and fill the canister 

 

Should I remove the top sponge?

 

Your advice would be appreciated 

Hello,
I've been using ROWA for years. I recall sometime back reading that GFO can drop alkalinity. My last tank had a dosing unit and was heavily packed with fish and coral. My tank now is much less bioload, but due to some fish loss and overfeeding my phosphates went through the roof. I've since corrected with a larger amount of ROWA, but my alk keeps dropping since I've been doing it. I'm wondering if the two are related. My alk was usually around 8, but dropping down to 6.5. Just wondering what your thoughts were? Should I perhaps dose a certain amount of alk when I change out my ROWA? I don;t really measure it out, I just use like 3 heaping spoonfuls in my 60 gallon and change every 3 weeks now. Thanks for any input and help you can give me. Oh, I should mention that my mag and cal stay high at 1400 mag and 460 cal.
Thank you,

Purchased 13 months ago complete with resin pod .noticed my marine tank NO3 
reading had increased over past 2 / 3 months to 10ppm from 0.25 no changes in 
my routines . After careful checking took readings from my unit and was 
surprised to 5ppm NO3. And the 80ltr tank of RO 10ppm.use this amount weekly
TDS reading into unit around 270 and after 6/7 ppm.
Decided to replace all cartridges including membrane and resin ,have produced 
a little over 25ltr and the TDS reading is now 3ppm. When 0 after 2ltr
Had replaces pre and carbon after 6 months.
Before the tap water reaches unit it has already passed through my Purity on 
Tap Hilux pre filter and chlornomore cartridges.

Hi Tony ,
                Can you help , I bought a deltec 1456 at xmas just gone 2016 , three weeks ago the pump never restarted after a routine water change now 4 months old . The shop was helpful and replaced free of with a new ddc2 pump but annoying said they'd had every pump back and that's why the 1455 was brought out , this is disgusting from both the shop and deltec to have continuing selling them models knowing the chances are they will break down ! It doesn't end there , for the last three weeks I've tried to sort the skimmer but it seems way too powerful and after about 45secs on the lower setting just foams over continuous , all the messing about has caused the tank to stress and I've lost two fish and have £350 of foam maker . Can you advise I've tried highering the skimmer and turned Venturi to both extremes . Should we have been a different air intake perhaps.

Tg

Hi,

I am having problem with my new reactor. At first I had the issue with the pump being too powerful for the phosphate remover so I followed the instructions to T off the water to make it less powerful. This works although it quickly gets an airlock and stop and just pumps out the second outlet of the T. The pump is fully submerged in the sump and I am completely stumped as to how the air is getting in to cause this.

Do you know any solutions to this issue.

Many thanks
Andy